Service intruption in Wolverton area

Minor incident Network Core
2026-07-29 15:00 BST · 23 hours, 1 minute

Updates

Resolved

The fibre has been repaired and service has now been restored.

July 30, 2026 · 13:58 BST
Update

Damage to the fibre caused by the Water Board investigating a leak.

We hope to get service reconnected by end of tomorrow.

July 29, 2026 · 17:00 BST
Issue

A small selection of customers will be experiencing a service interruption in the Wolverton area.

Our team is currently investigating.

July 29, 2026 · 15:00 BST

← Back